2022-07-04 14_17_41-EMAILMaker

Dear Vtiger Community, we are currently not supporting Vtiger 8.2. We are actively working on compatibility.

X